Windows 2003 – No tiene acceso al dispositivo

Intentamos ejecutar un archivo y nos devuelve este error:

“windows no tiene acceso al dispositivo, ruta de acceso o archivo especificado”

Haz click derecho, haz click sobre propiedades y haz click sobre el boton desbloquear al lado de donde indica: “Este archivo provino de otro equipo y puede que se bloquee para ayudar a proteger este equipo”

Event log file is corrupt

“Event Log file is corrupt” es un error que reproduce Event Viewer cuando contiene algún archivo de log corrupto o que contiene información no válida.  Dejo aquí algunos links que han servido de ayuda. En este caso, se solucionó (no sé si temporalmente o es permanente) clickando en el log que nos falla, Properties, y clickando en “Clear Log”.

Continue reading

Windows 2003 Server Autologin

A raíz del comentario de un usuario de este blog, dejo aquí este pequeño tip. Muy fácil de implementar. Sólo hemos de editar el registro.

  1. Abrimos el editor del registro (Inicio->Ejecutar “regedit”)
  2. Buscamos la siguiente ruta
  3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. Hemos de tener en cuenta las siguientes keys: DefaultUserName,DefaultPassword,AutoAdminLogon y DefaultDomainName. Si no están, hemos de crearlas (Botón Derecho->Nuevo->Valor Alfanumérico (REG_SZ).
  5. Estos son los valores que han de tener y como hemos de modificarlos:
  • DefaultUserName: nuestro usuario(tendrá que tener permisos de administrador)
  • DefaultPassword: añadimos nuestro pass(se añade en texto plano, sin encriptar ni algo parecido. Si alguien entra y lo ve, adiós secreto :P)
  • AutoAdminLogon: lo dejamos a 1
  • DefaultDomainName: el nombre del dominio del servidor

Cerramos editor y reiniciamos.

En mi caso, DefaultUser y DefaultDomainName ya estaban creadas. Pero no tiene más dificultad.

Saludos!

Links:

Reparar BD en modo Single User

Desconozco realmente el motivo que genera este problema, pero hace unos días una BD muy importante se me quedó en modo single user. Aparece un icono en la BD y cuando quieres hacer alguna tarea que otra te muestra el error. Por otro lado y esto es lo grave, parece ser que en este modo la BD queda innacesible para el resto de usuarios de SQL Server 2005, con lo que las conexiones a la BD son imposibles. El error era

The database Works is not accessible. (ObjectExplorer)

Para arreglarlo, ejecutamos

ALTER DATABASE [BD] SET MULTI_USER WITH NO_WAIT

o

EXEC sp_dboption 'BD', 'single user', 'false'

Comprobar y reiniciar servicio – WMI VBS script

Un pequeño script muy muy simple para comprobar el estado de un servicio en windows (lo comprobamos por el nombre) y reiniciarlo en el caso de que este caído.


Option Explicit
Dim objWMIService, objItem, objService, strServiceList
Dim colListOfServices, strComputer, strService
strComputer = "."
Set objWMIService = GetObject("winmgmts:" _
& "{impersonationLevel=impersonate}!\\" _
& strComputer & "\root\cimv2")
Set colListOfServices = objWMIService.ExecQuery _
("Select * from Win32_Service ")
For Each objService in colListOfServices
strServiceList = strServiceList & vbCr & _ objService.name
if objService.name = "NOMBRE_SERVICIO_A_CONTROLAR" Then
if objService.State = "Stopped" Then
objService.StartService()
End if
End if
Next
'objService.name
'objService.State
'objService.StartService()

Fuentes:

Windows 2003 – Error al instalar archivos de catálogo

En inglés “Failed to install catalog files”. Este error se produce al intentar aplicar una actualización o Service Pack en Windows 2003. Por fin he tenido unos minutos que dedicarle al tema y encontré la solución. Pero no fue ninguna de las que proponía el documento de Microsoft al respecto.

Seguí estos pasos:

1) Abrimos prompt (Inicio -> Ejecutar)

# net stop cryptsvc
# ren %systemroot%\System32\Catroot2 oldcatroot2
# net start cryptsvc


2) Borramos archivos temporales que empiezen por tmp*.cat en %systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}

http://forums.techarena.in/showthread.php?t=253400

Habilitar recurso administrador c$

1) Inicio->Herramientas Administrativas->Servicios

Hemos de comprobar que el servicio “Server” esté activado y en modo “Automático”. Es el primer requisito y indispensable para que funcione el recurso de administrador (y que haya conexión entre las máquinas, obviously).

2) Inicio->Herramientas Administrativas->Administración de Equipo

Dentro de la consola, buscamos las carpetas compartidas, donde veremos el recurso c$. Desde ahí lo podremos desactivar o activar.